CLI & Routing
Zurück zum Seitenanfang | Publiziert amRouting aktivieren
ip routing
Routen anzeigen
show ip route
show ip route summary
Hier werden lediglich einzelne CLI Befehle aufgeführt. Es findet sich hier keine Anleitung um bestimmte Switching Szenarien umzusetzen. Vielleicht kommt das noch, doch momentan dienen die einzelnen Bereiche als Gedächnisstütze.
ip routing
show ip route
show ip route summary
dhcp-relay
show dhcp-relay
vlan 1000 ip helper-address 10.1.1.10
show ip helper-address vlan-1000
router ospf enable
vlan 1000
name "Example-Net"
untagged 1/1-47
tagged Trk1
ip ospf 10.1.1.1 area backbone
ip ospf 10.1.1.1 authentication-key "xxxxxxxx"
ip ospf 10.1.1.1 passive
show ip ospf
show ip ospf general
show ip ospf interface vlan 1000
show ip ospf external-link-state
show ip ospf neighbor detail
show ip ospf statistics vlan 1000
show ip ospf neighbor 10.1.1.1
show ip ospf redistribute
show ip ospf restrict
route-map "export-ospf" permit seq 10
match source-protocol connected
router ospf
area backbone
redistribute connected route-map "export-ospf"
enable
show vlans
show vlans 1000
show vlan port a1-a24
show vlan port a1-a24 detail
show vlan custom a1-a3 id name:20 ipaddr state
show vlan custom id
management vlan 1000
primary-vlan 1000
vlan 1000 name 1000-clients
vlan 1000 protocol ipv4
vlan 1000 protocol arp
no vlan 1000
static-vlan 1000
vlan 1000 tagged a1-a5
disable layer3 vlan 1000
no interface 1,6,7-10 tagged vlan 1,3,5-10
interface 2 forbid vlan 4-5
gvrp
no gvrp
interface 1-2 unknow-vlans block
interface 3 unknown-vlans learn
interface 4-5 unknown-vlans disable
spanning-tree
spanning-tree mode mstp
spanning-tree config-name "NETWORK"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1000
spanning-tree instance 1 priority 4096
spanning-tree 1-4,5,7 admin-edge-port
spanning-tree 1-4,5,7 mcheck
spanning-tree 1-4,5,7 root-guard
spanning-tree 1-4,5,7 tcn-guard
spanning-tree 1-4,5,7 bpdu-filter
spanning-tree trap [errant-bpdu|loop-guard|new-root|root-guard]
spanning-tree show port configuration
show spanning-tree
show spanning-tree bpdu-protection
show spanning-tree 1-4,5,7 detail
show spanning-tree detail
show spanning-tree root-history
show spanning-tree debug-counters
show spanning-tree traps
show spanning-tree root-history cst
show spanning-tree root-history ist
show spanning-tree root-history mst
show spanning-tree debug-counters instance 1
show spanning-tree debug-counters instance 2 port a14
show spanning-tree root-history vlan 1000
show spanning-tree debug ports 9 vlan 1020
spanning-tree clear-debug-counters
loop-protect mode port
loop-protect mode vlan
loop-protect 1-2
loop-protect 1-2 receiver-action send-disable
loop-protect vlan 20, 30
spanning-tree 1-2 loop-guard
show loop-protect 1-2,5,7
timesync sntp
sntp unicast
sntp server priority 1 10.1.1.10
time daylight-time-rule western-europe
time timezone 60
ip dns server-address priority 1 10.1.1.5
ip dns server-address priority 2 10.1.1.6
ip dns domain-name example.com
ip access-list standard example-access-list
permit host 10.10.10.100
deny 10.10.10.1/24 log
permit any
show access-list example-access-list config
access-list 10 permit host 10.10.10.100
access-list 10 deny 10.10.10.1/24 log
access-list 10 permit any
show access-list 10
ip access-list extended example-extended-list
permit tcp host 10.10.10.100 host 10.10.10.200 eq telnet
deny ip 10.10.10.1/24 10.10.20.1/24
permit ip any any
vlan 1001 ip access-group example-extended-list in
show statistics aclv4 example-ipv4-acl vlan 1020 vlan
show arp-protect
arp-protect trust b1-b4, d1
show port-security
show arp-protect statistics
debug arp-protect
show mac-address
port security a1 learn-mode static address-limit 2 mac-address 00c1c2-d1d2d3d4 00a1a2-b1b2b3b4 action send-alarm
clear mac-address port <port-list>
clear mac-address vlan 1000 mac <mac-address>
debug dynamic-ip-lockdown
show ip source-lockdown status
port-security a mac-address 0ca1b4-132456
show port-security intrusion-log
clear intrusion-flags
show logging -a
show logging -b
show logging -r -a
show logging -e
show logging -d
logging origin-id [hostname|ip-address|none]
logging 10.1.1.100 [udp 514|tcp 1470|tls 6514]
logging severity [debug|major|error|warning|info]
logging facility [user|kern|mail|daemon|auth|auth|syslog|lpr|news|uucp|cron|sys9|sys10-sys14|local10-local17]
logging filter <name> [enable|disable]
clear logging filter <name|all>
show logging filter <name>
logging filter "noUpPorts" 10 "(A10|A22|B5) is now-online" deny
logging filter "noUpPorts" default permit
logging filter "SevWarnFatal" 10 severity warning permit
logging filter "SevWarnFatal" 20 severity major permit
logging filter "SevWarnFatal" default deny
logging filter "noUpDownEvents" 10 event-num 76 deny
logging filter "noUpDownEvents" 20 event-num 77 deny
logging filter "noUpDownEvents" default permit
logging filter "noStpBlockPorts" 10 "(A[1-9]|A10|B[1-4]) .*Blocked by STP" permit
logging filter "noStpBlockPorts" 20 " .*Blocked by STP" deny
logging filter "noStpBlockPorts" default permit
show debug
debug [acl|all|destination|event|ip|lldp|lacp|security|services|snmp|vrrp|wireless-services]
debug destination session
debug destination logging
no debug destination logging
debug <debug type> include [ip|port|vlan]
debug snmp event include ip 10.1.1.20
debug ip rip database include port 14
show config
show running-config
chassislocate [blink|on|off]
show interfaces transceiver 1/49 detail
show interfaces transceiver all detail
show tech
show boot-history
show history
show system-information
show version
show interfaces
show interfaces-display
show run | include ipv6
show run | exclude ipv6
show run | begin vlan
show arp | include 10.1.1.10
test cable-diagnostics 1/22,1/26-30
ip authorized-managers 10.10.10.0 255.255.255.0 access manager
ip authorized-managers 10.10.10.0 255.255.255.0 manager access-method ssh